[RV226..229.1165] Thea for SketchUp 32/64!

Development versions, documentation, tutorials and application resources may be found here.

Moderator: Tomasz

User avatar
Tomasz
Thea Developer
Thea Developer
Posts: 9239
Joined: Fri Jul 18, 2008 5:09 pm
Has thanked: 193 times
Been thanked: 107 times
Contact:

Hello All,

Here it comes a new revision of the plugin with a support for SketchUp 2015 x64

RV229 fixes:
- SketchUp materials in localized versions (IT,FR,..) can be edited now
- SketchUp materials in localized versions keep their original names in Mat-Lab/Studio now

RV227 bug-fixes:
- previews of edited material are shown correctly also for mats imported through Thea Browser
- [Mac] SU6-8 Thea doesn't crash when opened (regression bug)
- [Mac] Mat-Lab opens correctly even when Thea.app is in a path including spaces

RV226 bug-fixes:
- relative path support for loading and displaying external dependencies (/ModelName_files/ )
- fix for "Container" for Lights
- roughness control exposed for Colored Metal preset
- Thea Image removed from animation export options (not supported)
- FrontFace material is added only when necessary
- Default Preset handles correctly textured SU Material with alpha map AND opacity<1.0
- Display Settings show correct default values of Vignetting,Chroma,Contrast
- WhiteBalance checkbox is enabled when WB value changes
- fix for IR Preset first time modification for a SketchUp material #1274

Enjoy full memory address space with SU2015 64 bit!

Please visit our download thread (for licensed users only).
slave
Licensed User v1.5
Licensed User v1.5
Posts: 269
Joined: Tue Mar 29, 2011 4:50 am
Location: UAE / Macedonia
Has thanked: 26 times
Been thanked: 70 times

Thank you Tomasz.

I install version of sketchup 2015(trial) and [RV226.1165] Thea for SketchUp 64 just to try.

I find this:
When you use thea tool and you chose material, in preview window(thea tool) is not showing assigned material, always is blank.
Material is assigned, you can see if you edit in mat-lab, even is rendering with that material, only preview in thea tool is blank.
archigrafix
Licensed User v1.5
Licensed User v1.5
Posts: 259
Joined: Wed May 20, 2009 1:26 pm
Location: PARIS
Has thanked: 0
Been thanked: 0
Contact:

Cool! thank you very much Tomasz! :shock: :shock: :shock:
User avatar
saurus
Licensed User v1.5
Licensed User v1.5
Posts: 1101
Joined: Sun Oct 11, 2009 10:12 am
Location: Serbia
Has thanked: 61 times
Been thanked: 55 times
Contact:

Great! Thank you! :clap:
User avatar
Tomasz
Thea Developer
Thea Developer
Posts: 9239
Joined: Fri Jul 18, 2008 5:09 pm
Has thanked: 193 times
Been thanked: 107 times
Contact:

slave wrote:Material is assigned, you can see if you edit in mat-lab, even is rendering with that material, only preview in thea tool is blank.
Have you been asked for admin password when running the installer? If not, can you re-installl the plugin by right-clicking on the exe and selecting "Run as administrator"?
User avatar
Frederik
Thea A Team
Thea A Team
Posts: 5581
Joined: Fri Jul 18, 2008 2:24 pm
Location: Denmark
Has thanked: 43 times
Been thanked: 100 times

I haven't noticed this previously - most likely because I'm more used to apply Thea Materials using the Thea Browser... :oops:
I believe Slave is right... There seem to be something broken, when using the Thea Tool...

Double-click a material and apply a material in the Thea Mat Editor and click accept...
The small window, where the material is supposed to be seen is just blank... :think:
Cheers
Kim Frederik

"If you have no critics you'll likely have no success..."
-Malcolm X
User avatar
gerciowski
Licensed User v1.5
Licensed User v1.5
Posts: 25
Joined: Mon Mar 12, 2012 10:55 am
Location: Toruń, Poland
Has thanked: 0
Been thanked: 0

Wow, Thank you Tomasz, that's the speed :D
slave wrote:Thank you Tomasz.

I install version of sketchup 2015(trial) and [RV226.1165] Thea for SketchUp 64 just to try.

I find this:
When you use thea tool and you chose material, in preview window(thea tool) is not showing assigned material, always is blank.
Material is assigned, you can see if you edit in mat-lab, even is rendering with that material, only preview in thea tool is blank.
Found the same behavior with this revision of plugin but with sketchup ver.8. Plugin was installed with "Run as administrator", even if i reasign material within mat-lab, material preview in thea tool window remains empty.
Last edited by gerciowski on Tue Nov 04, 2014 2:05 pm, edited 1 time in total.
User avatar
nigec
Thea Beta Tester
Thea Beta Tester
Posts: 10520
Joined: Wed Jul 01, 2009 9:47 pm
Location: UK
Has thanked: 60 times
Been thanked: 52 times

Frederik wrote:I haven't noticed this previously - most likely because I'm more used to apply Thea Materials using the Thea Browser... :oops:
I believe Slave is right... There seem to be something broken, when using the Thea Tool...

Double-click a material and apply a material in the Thea Mat Editor and click accept...
The small window, where the material is supposed to be seen is just blank... :think:
Likes, I use the browser

But yes indeed with 2013 and 2015 this seems to be broken

(tried installing as an admin)
"Life is what happens to you while you're busy making other plans."
My Gallery
User avatar
Solo
Licensed User v1.5
Licensed User v1.5
Posts: 3647
Joined: Fri May 15, 2009 9:15 pm
Location: Dallas, Texas
Has thanked: 2 times
Been thanked: 14 times

Works for me.
xannot replicate.jpg
User avatar
Frederik
Thea A Team
Thea A Team
Posts: 5581
Joined: Fri Jul 18, 2008 2:24 pm
Location: Denmark
Has thanked: 43 times
Been thanked: 100 times

Solo wrote:Works for me.
:problem: Not sure I get what you mean, Pete...?!?
Attachments
xannot-replicate_KFB.jpg
Cheers
Kim Frederik

"If you have no critics you'll likely have no success..."
-Malcolm X
Post Reply

Return to “Versions & Resources (SketchUp)”