Thea Presto Benchmark Thread

A forum especially for contests and Hall of Fame.

by Anthony » Thu Jul 31, 2014 10:07 am

Welcome to the Thea Render Benchmark Thread!

This thread is dedicated to showcase benchmark results provided by community members which showcase performance of Thea Presto engine on their system. To submit a benchmark the instructions are really simple. Simply download the script attached in this post and please make sure you have the benchmark scenes installed on your system.

To install the benchmark scenes you need to open Thea Render Studio and select Help - Check for Updates option. Licensed users will have the benchmark scenes available for download and once installed execute the script file. Execution time is 10 minutes for the benchmark to complete.

Once results are generated, copy the contents of the console into a text file and attach it to your post reply in this thread along with basic system specs of your machine (CPU, memory, GPU, operating system). All results will be gathered and added to the benchmark table for all the community to see and of course discuss.

Should you have any questions related to the benchmark, please send us your comments at contact@thearender.com

*Note*: Please use either RV1115 or RV1130 for benchmarking with Low priority for all devices.
Attachments
PrestoBenchmark.ipt.thea
(988 Bytes) Downloaded 630 times
User avatar
Anthony
Thea Licensed User
Thea Licensed User
 
Posts: 2033
Joined: Wed Jan 08, 2014 9:33 am

by muzer » Thu Jul 31, 2014 8:07 pm

Hi Anthony,

When I run the script it fails on line 5 "SaveFilm CausticsBenchmark2m.img.thea"

Here is a text from the console:
Code: Select all
Installed library "Presto Benchmark Scenes" by Solid Iris Technologies version 1.0

Using application folder /Applications/Thea.app/Contents/MacOS
Using config folder /Users/USER/Library/Application Support/Thea Render
Using data folder /Users/USER/Library/Application Support/Thea Render
Using plugin folder /Applications/Thea.app/Contents/MacOS/Plugins
Using temporary session folder /Users/USER/Documents/_Apps/Rendering/Thea/_Temp/Session_00000029
Using presto driver revision 1115

Using stored material editor scene "direct/direct"
Using stored material editor scene "direct/direct"
Inspecting script "/Users/USER/Documents/_Apps/Rendering/Thea/Test/Benchmarks/PrestoBenchmark.ipt.thea"
Executing script "/Users/USER/Documents/_Apps/Rendering/Thea/Test/Benchmarks/PrestoBenchmark.ipt.thea"
Device #0: Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz
Building Environment... done. (0.10122 seconds)
- Polys: 13520, Objects: 5, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 1336, Leaves: 4009, Cache Level: Normal
Device #0: memory ?/0 Mb
Device #0: 75x4 s/p
Finished in 121 seconds
Finished in 2 minutes and 1 seconds!
Failed during parsing message "SaveFilm CausticsBenchmark2m.img.thea"
Error at line 5: message "SaveFilm CausticsBenchmark2m.img.thea"

Finished in 121 seconds!
OS X 10.9.4 (13E28)
Thea Presto2 Edition v1.3.06 Build 1115 Mac OS X
3.2 GHz Intel Core i5
32 GB 1600 MHz DDR3
NVIDIA GeForce GT 755M 1024 MB

Let me know if you need additional details.
muzer
Thea Licensed User
Thea Licensed User
 
Posts: 48
Joined: Fri May 29, 2009 10:53 pm

by SamHowell » Thu Jul 31, 2014 9:02 pm

Yo yo, here we are:

Code: Select all
Using stored material editor scene "direct/direct"
Using stored material editor scene "direct/direct"
Inspecting script "C:\Users\Sam\Downloads\PrestoBenchmark.ipt.thea"
Executing script "C:\Users\Sam\Downloads\PrestoBenchmark.ipt.thea"
Device #0: GeForce GTX TITAN Black
Building Environment... done. (0.32 seconds)
- Polys: 13520, Objects: 5, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 4199, Leaves: 4200, Cache Level: Normal
Device #1: GeForce GTX TITAN Black
Device #0: memory 618/6144 Mb
Device #1: memory 618/6144 Mb
Device #1: 481x4 s/p
Device #0: 439x4 s/p
Finished in 2 minutes and 2 seconds!
Device #0: GeForce GTX TITAN Black
Building Environment... Note: activating instancing mode for saving memory.
done. (0.641 seconds)
- Polys: 138667997609, Objects: 1063033, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 531516
- Instances: 1063028, Portals: 0
- Nodes: 646652, Leaves: 646657, Cache Level: Normal
Device #1: GeForce GTX TITAN Black
Device #0: memory 1530/6144 Mb
Device #1: memory 1530/6144 Mb
Device #0: 38 s/p
Device #1: 38 s/p
Finished in 2 minutes and 6 seconds!
Device #0: GeForce GTX TITAN Black
Building Environment... done. (0.94 seconds)
- Polys: 503556, Objects: 91, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 158062, Leaves: 158063, Cache Level: Normal
Device #1: GeForce GTX TITAN Black
Device #Device #1: memory 9210/: memory 6144 Mb
921/6144 Mb
Device #0: 311x4 s/p
Device #1: 316x4 s/p
Finished in 2 minutes and 0 seconds!
Device #0: GeForce GTX TITAN Black
Building Environment... done. (0.15 seconds)
- Polys: 48218, Objects: 23, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 13736, Leaves: 13725, Cache Level: Normal
Device #1: GeForce GTX TITAN Black
Device #Device #10: memory : memory 822822//61446144 Mb
 Mb
Device #1: 66x4 s/p
Device #0: 81x4 s/p
Finished in 2 minutes and 0 seconds!
Finished in 491 seconds!


Windows 8.1 Pro - 64 Bit
Thea Presto v1.3.06 Build 1115
i7-4930K CPU@3.40GHz
RAM - 32GB
Dual NVIDIA GeForce GTX TITAN Black
Attachments
Sam_Howell_Presto_Benchmark.txt
(1.99 KiB) Downloaded 188 times
User avatar
SamHowell
Thea Licensed User
Thea Licensed User
 
Posts: 346
Joined: Wed Mar 31, 2010 9:49 am
Location: Birmingham

by youyou40 » Fri Aug 01, 2014 7:17 am

Hello

Code: Select all
Using stored material editor scene "direct/direct"
Using stored material editor scene "direct/direct"
Inspecting script "C:\Users\Utilisateur\Downloads\PrestoBenchmark.ipt.thea"
Executing script "C:\Users\Utilisateur\Downloads\PrestoBenchmark.ipt.thea"
Device #0: GeForce GTX 770
Building Environment... done. (0.5 seconds)
- Polys: 13520, Objects: 5, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 4199, Leaves: 4200, Cache Level: Normal
Building Environment... done. (0.5 seconds)
- Polys: 13520, Objects: 5, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 1336, Leaves: 4009, Cache Level: Normal
Device #1:  Intel(R) Core(TM) i7-4930K CPU @ 3.40GHz
Device #1: memory 2281/16319 Mb
Device #0: memory 454/4096 Mb
Device #1: 144x4 s/p
Device #0: 220x4 s/p
Finished in 2 minutes and 0 seconds!
Device #0: GeForce GTX 770
Building Environment... Note: activating instancing mode for saving memory.
done. (0.657 seconds)
- Polys: 138667997609, Objects: 1063033, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 531516
- Instances: 1063028, Portals: 0
- Nodes: 646652, Leaves: 646657, Cache Level: Normal
Building Environment... Note: activating instancing mode for saving memory.
done. (0.624 seconds)
- Polys: 138667997609, Objects: 1063033, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 531516
- Instances: 1063028, Portals: 0
- Nodes: 167262, Leaves: 501791, Cache Level: Normal
Device #1:  Intel(R) Core(TM) i7-4930K CPU @ 3.40GHz
Device #1: memory 3659/16319 Mb
Device #0: memory 866/4096 Mb
Device #0: 31 s/p
Device #1: 38 s/p
Finished in 2 minutes and 4 seconds!
Device #0: GeForce GTX 770
Building Environment... done. (0.93 seconds)
- Polys: 503556, Objects: 91, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 158062, Leaves: 158063, Cache Level: Normal
Building Environment... done. (0.109 seconds)
- Polys: 503556, Objects: 91, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 40851, Leaves: 122554, Cache Level: Normal
Device #1:  Intel(R) Core(TM) i7-4930K CPU @ 3.40GHz
Device #1: memory 2714/16319 Mb
Device #0: memory 533/4096 Mb
Device #0: 179x4 s/p
Device #1: 126x4 s/p
Finished in 2 minutes and 1 seconds!
Device #0: GeForce GTX 770
Building Environment... done. (0.12 seconds)
- Polys: 48218, Objects: 23, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 13736, Leaves: 13725, Cache Level: Normal
Building Environment... done. (0.12 seconds)
- Polys: 48218, Objects: 23, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 4211, Leaves: 12621, Cache Level: Normal
Device #1:  Intel(R) Core(TM) i7-4930K CPU @ 3.40GHz
Device #0: memory 491/4096 Mb
Device #1: memory 2457/16319 Mb
Device #0: 51x4 s/p
Device #1: 60x4 s/p
Finished in 2 minutes and 1 seconds!
Finished in 487 seconds!


Windows 8.1 64bit
Presto2 Edition v1.3.07 Build 1130
i7-4930K CPU @ 3.40GHz
GTX 770 4G
Ram 16 G
youyou40
Thea Licensed User
Thea Licensed User
 
Posts: 161
Joined: Sun Jan 05, 2014 5:17 pm
Location: Landes; France

by giannis » Fri Aug 01, 2014 7:51 am

muzer wrote:Hi Anthony,

When I run the script it fails on line 5 "SaveFilm CausticsBenchmark2m.img.thea"

Do you have read only permissions where the image is saved? It is the folder where the script is saved.
In anyway, you can uncheck the "Stop on Error" check when opening the script. This will execute all renders, failure to save the buffers is not an issue for the console log that we want.

Best wishes
Science may limit knowledge but should never limit imagination - Bertrand Russell
User avatar
giannis
Thea Developer
Thea Developer
 
Posts: 7820
Joined: Sun Jul 06, 2008 8:25 pm
Location: Athens, Greece

by giannis » Fri Aug 01, 2014 8:02 am

Something to note:
1. Please use either RV1115 or RV1130 for benchmarking.
2. Please use Low priority (ie default value) for all devices.

This way there will be consistency between all results and it will allow us to build a "map" between hardware/systems and thea performance. It is quite important since what we want to achieve here is to have a reference for everyone that wants to have an idea how thea presto will perform on a certain system.

This means that the more systems/entries we have, the more complete our reference performance guide will be.

Best wishes
Science may limit knowledge but should never limit imagination - Bertrand Russell
User avatar
giannis
Thea Developer
Thea Developer
 
Posts: 7820
Joined: Sun Jul 06, 2008 8:25 pm
Location: Athens, Greece

by nigec » Fri Aug 01, 2014 8:23 am

just for a laugh
i7 3770k unclocked
8gb ram
slightly sick Quadro 600
RV1130
Win7
Code: Select all
Device #0: Quadro 600
Building Environment... done. (0.30 seconds)
- Polys: 13520, Objects: 5, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 4199, Leaves: 4200, Cache Level: Normal
Building Environment... done. (0.10 seconds)
- Polys: 13520, Objects: 5, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 1336, Leaves: 4009, Cache Level: Normal
Device #1:  Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz
Device #1: memory 3121/8143 Mb
Device #0: memory 238/1024 Mb
Device #1: 100x4 s/p
Device #0: 26x4 s/p
Finished in 2 minutes and 1 seconds!
Device #0: Quadro 600
Building Environment... Note: activating instancing mode for saving memory.
done. (0.652 seconds)
- Polys: 138667997609, Objects: 1063033, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 531516
- Instances: 1063028, Portals: 0
- Nodes: 646652, Leaves: 646657, Cache Level: Normal
Building Environment... Note: activating instancing mode for saving memory.
done. (0.642 seconds)
- Polys: 138667997609, Objects: 1063033, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 531516
- Instances: 1063028, Portals: 0
- Nodes: 167262, Leaves: 501791, Cache Level: Normal
Device #1:  Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz
Device #0: memory 609/1024 Mb
Device #1: memory 4353/8143 Mb
Device #0: 3 s/p
Device #1: 25 s/p
Finished in 2 minutes and 2 seconds!
Device #0: Quadro 600
Building Environment... done. (0.100 seconds)
- Polys: 503556, Objects: 91, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 158062, Leaves: 158063, Cache Level: Normal
Building Environment... done. (0.110 seconds)
- Polys: 503556, Objects: 91, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 40851, Leaves: 122554, Cache Level: Normal
Device #1:  Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz
Device #0: memory 311/1024 Mb
Device #1: memory 3435/8143 Mb
Device #1: 86x4 s/p
Device #0: 20x4 s/p
Finished in 2 minutes and 2 seconds!
Device #0: Quadro 600
Building Environment... done. (0.10 seconds)
- Polys: 48218, Objects: 23, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 13736, Leaves: 13725, Cache Level: Normal
Building Environment... done. (0.10 seconds)
- Polys: 48218, Objects: 23, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 4211, Leaves: 12621, Cache Level: Normal
Device #1:  Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz
Device #1: memory 3104/8143 Mb
Device #0: memory 253/1024 Mb
Device #1: 42x4 s/p
Device #0: 6x4 s/p
Finished in 2 minutes and 15 seconds!
Finished in 505 seconds!
User avatar
nigec
Thea Licensed User
Thea Licensed User
 
Posts: 9212
Joined: Wed Jul 01, 2009 9:47 pm
Location: UK

by muzer » Fri Aug 01, 2014 11:25 am

giannis wrote: ... Do you have read only permissions where the image is saved? It is the folder where the script is saved.
In anyway, you can uncheck the "Stop on Error" check when opening the script. This will execute all renders, failure to save the buffers is not an issue for the console log that we want. ...
I do have full read/write permissions and see that Thea is adding files to the folders.

I did run the script with the "Stop on Error" option disabled and it finished fine. Attached are the results from the console.
Attachments
Benchmark-Presto1115-muzer.txt
(3.95 KiB) Downloaded 163 times
muzer
Thea Licensed User
Thea Licensed User
 
Posts: 48
Joined: Fri May 29, 2009 10:53 pm

by JGA » Fri Aug 01, 2014 12:55 pm

Attached is the log & PC spec.
My Thea scenes folder doesn't have a benchmark sub-folder
EDIT - I need to update my version to include the benchmark; disregard my console log for the moment.

EDIT (2) - I updated Thea Studio, but it still doesn't appear to have the Benchmark Scenes folder. Is this a separate download? I can't use the Check for Updates utility, as its blocked by our firewall. Thanks for any help anyone can provide.
Attachments
spec.png
PC Specification
spec.png (3.19 KiB) Viewed 6618 times
Last edited by JGA on Tue Aug 05, 2014 4:11 pm, edited 1 time in total.
JGA
Thea Licensed User
Thea Licensed User
 
Posts: 94
Joined: Mon May 11, 2009 3:17 pm
Location: Scotland

by naudofr » Fri Aug 01, 2014 2:42 pm

Hi,

here is mine :

Windows 7 64 bits
i7 2600K CPU @ 3.40 Ghz
RAM 16 Go
RV 1130
Titan

thea_benchmark.txt
(3.69 KiB) Downloaded 266 times
User avatar
naudofr
Thea Beta Tester
Thea Beta Tester
 
Posts: 998
Joined: Fri May 21, 2010 7:32 pm
Location: Nice (France)

Next

Return to Contests / Benchmarks / Polls